Single file graph app example just "spins" (doesn't load). I followed instructions

(Fruitfulapproach) #1

Here's a picture of the tutorial page that shows what I expect to see, and then on the right, what happens when I click "Development App" within Neo4j Desktop.

0 Likes

(M. David Allen) #2

Please post the code of the app you're trying to deploy, and identify where that spinner is.

Additionally - normally you need to fill out the "Deployment app entry point" which your screenshot shows is blank, as well as app root path. You should set these values to http://localhost:3000/ (or wherever your app is running) and the the second one to the absolute path to your code, as in /Users/me/code/my-graphapp/

Other than this, I'm sorry the question doesn't have enough details for me to help further. Please identify how you're starting your app & where your code is.

0 Likes

(Fruitfulapproach) #3

Thank you @david.allen

I looked up the docs again and found this by chance:

Read the beginning of the README.md and you'll see it says exactly what I'm missing.

0 Likes

(Fruitfulapproach) #4

Actually I've put this in:

Entry point: file:\C:\Users\FruitfulApproach\Desktop\graph-app-starter\examples\basic-single-file\index.html
Root path: C:\Users\FruitfulApproach\Desktop\graph-app-starter\examples\basic-single-file\index.html

And am getting a blank app, but spinning goes away.

0 Likes

(M. David Allen) #5

The entrypoint is wrong. Please see my message above, it should be a URL not a file path, and it should correspond to where you have the app running.

Neo4j Desktop does not run the app for you in development mode, you run it separately via JavaScript and provide the URL to the application.

0 Likes

(Fruitfulapproach) #6

@david.allen I've observed in the examples that yes that's correct, however, the basic-single-file example has the file location as teh entry point.

So....?

0 Likes