OSM Import plugin generation error

I've been trying to install the newer OSM import plugin for neo4j. using the maven clean intstall (have tried using maven 3.6.1 and 3.6.1/ java jdk 11.0.3 and 12.0.1)running into a build error:

'The code being documented uses modules but the packages defined in http://docs.oracle.com/javase/7/docs/api/ are in the unnamed module.'

Not really neo4j but I'm not a Java developer. Anyone know how to fix this.?


Try it with java 8, that should work.

Thanks for that! That worked fine, using Java 8. However, I'm now trying to import an OSM file... trying to follow the instructions on Git..I take it I just run these through the windows command prompt with my path values for target database and source files replaced...it's not working falls over with first error ...Error: Could not find or load main class \ ??? have no idea how to proceed. Any direction would be most appreciated. Thanks.

Are there more details to the error message?

Hi,I've tried regigging the paths ; the last full error is:

Error: Could not find or load main class \

C:\Users\Kimmo\Development\Graph\Spatial\osm-master\osm-master> "target/osm-0.2.2-neo4j-3.5.1.jar:target/dependency/" org.neo4j.gis.osm.OSMImportTool
"' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Kimmo\Development\Graph\Spatial\osm-master\osm-master> into target/databases/map2 samples/map2.osm.bz2


What was the command line you ran.