Neomodel still using 127.0.0.1 on heroku host regardless of heroku config:set variables

This screenshot has most of the data in the error as well the environment config on heroku. I did a commit / push to heroku when I made code changes just now, so it should be working. I store my credentials in git-ignored IDE project file, and on heroku I've used heroku config:set BLAH=blah to set them on that side. It's not picking them up.


I could really use some help on this one.

where / how do you call settings.py ?

Could you log the value of the URL and see if it actually calls your function?

I am unable to log inside of settings.py, though it does get called after all it's Django on Heroku (the default getting-started app is Django).

Thanks to your prodding I looked at it again, and now I'm getting:

So I'll talk to my host about correct hostname for that port. @michael.hunger

So I was able to print() from settings.py and it does print the correct URL now. Maybe it took a few restarts on Heroku for config to click into gear.