# Neo4J Docker Intermittent Error (Lock Manager Not Found)

**URL:** https://community.neo4j.com/t/neo4j-docker-intermittent-error-lock-manager-not-found/44129
**Category:** Docker
**Created:** [September 8, 2021, 3:05pm UTC](https://community.neo4j.com/t/neo4j-docker-intermittent-error-lock-manager-not-found/44129 "2021-09-08T15:05:45Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![ben6](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/ben6/32/15087_2.png) [@ben6](https://community.neo4j.com/u/ben6)
#### Post date: [September 8, 2021, 3:05pm UTC](https://community.neo4j.com/t/neo4j-docker-intermittent-error-lock-manager-not-found/44129/1 "2021-09-08T15:05:45Z")

</div>

Hey guys,

I'm getting the following intermittent error (maybe half the time) when starting up Neo4J in docker locally. Can anyone help diagnose the issue? Thanks.

```auto
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@352c1b98' was successfully initialized, but failed to start. Please see the attached cause exception "No lock manager found".

```

Here is the command i use to run with docker.

```auto
docker run -p 7687:7687 -p 7474:7474 \
     -v $PWD/neo4j-dev/plugins:/plugins \
     -e NEO4J_apoc_export_file_enabled=true \
     -e NEO4J_apoc_import_file_enabled=true \
     -e NEO4J_apoc_import_file_use __neo4j__ config=true \
     -e NEO4J_dbms_security_procedures_unrestricted=apoc.\\\*,gds.\\\* \
     --platform linux/amd64 \
     --env NEO4J_AUTH=neo4j/password \
     neo4j:4.0

```
