# Neo4j Desktop version not coming up with upgrade of APOC

**URL:** <https://community.neo4j.com/t/neo4j-desktop-version-not-coming-up-with-upgrade-of-apoc/7162>\
**Category:** Server\
**Tags:** apoc\
**Created:** [May 6, 2019, 3:28pm UTC](https://community.neo4j.com/t/neo4j-desktop-version-not-coming-up-with-upgrade-of-apoc/7162 "2019-05-06T15:28:15Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![intouch\_vivek](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/intouch_vivek/32/4097_2.png) [@intouch\_vivek](https://community.neo4j.com/u/intouch_vivek)\
**Post date:** [May 6, 2019, 3:28pm UTC](https://community.neo4j.com/t/neo4j-desktop-version-not-coming-up-with-upgrade-of-apoc/7162/1 "2019-05-06T15:28:15Z")

</div>

I upgraded my application to Neo4j 3.5.4 also installed APOC 3.5.0.3 .  
Problem:  
I can bring my desktop server up if I do not install APOC however with APOC it is not coming up and throwing error like  
**\> 019-05-06 15:14:48.650+0000 ERROR Failed to start Neo4j: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@64078e6a' was successfully initialized, but failed to start. Please see the attached cause exception "Unable to register procedure, because the name `apoc.metrics.get` is already in use.". Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@64078e6a' was successfully initialized, but failed to start. Please see the attached cause exception "Unable to register procedure, because the name `apoc.metrics.get` is already in use.".**  
**\> org.neo4j.server.ServerStartupException: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@64078e6a' was successfully initialized, but failed to start. Please see the attached cause exception "Unable to register procedure, because the name `apoc.metrics.get` is already in use.".**  
**\> at org.neo4j.server.exception.ServerStartupErrors.translateToServerStartupError(ServerStartupErrors.java:45)**

---

<div class="post-metadata">

**Author:** ![david\_allen](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/david_allen/32/13090_2.png) [@david\_allen](https://community.neo4j.com/u/david_allen)\
**Post date:** [May 6, 2019, 5:10pm UTC](https://community.neo4j.com/t/neo4j-desktop-version-not-coming-up-with-upgrade-of-apoc/7162/2 "2019-05-06T17:10:33Z")

</div>

Is it possible you have two different versions of APOC installed?

What is in your plugins directory?

---

<div class="post-metadata">

**Author:** ![intouch\_vivek](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/intouch_vivek/32/4097_2.png) [@intouch\_vivek](https://community.neo4j.com/u/intouch_vivek)\
**Post date:** [May 6, 2019, 5:52pm UTC](https://community.neo4j.com/t/neo4j-desktop-version-not-coming-up-with-upgrade-of-apoc/7162/3 "2019-05-06T17:52:18Z")

</div>

thanks. It was version issue I had two version of APOC in the upgraded version of Neo4j
