Neo4j Desktop Issue

Okay, could you rename this folder to something else (for example .Neo4jDesktop-old) and restart Desktop?

1 Like

Yeyyy! I can see the Screen now. Thank you very much! :grinning:

1 Like

I still need to use my old graph databases which are populated with Neo4j. How can I do such old graph databases with this new one? They are located in different location path...

Do you have a lot of them, or just a few? And what version of Neo4j are they using?

It's not possible to import them automatically, but there are a few ways that you can do that manually. How easy that will be depends on whether the Neo4j version they are running is still supported.

1 Like

They are created with Neo4j 4.0.1. I have a lot. Three different graphs data. If there are few ways that I can do that manually, I will do. Thanks!

Okay, great that they are using 4.0.1, that will work fine with Desktop, and you won't need to manually upgrade them first.

Just to make sure I understood correctly, you have three Neo4j instances, which contain a lot of data, right? Does each instance contain multiple databases or only one each?

1 Like

I think each instance contain only one database. Here are my old data that I tested ..

Alright, the safest solution in your case would be to create dump files from the old databases, move those files into Desktop and then create new DBMSs (Neo4j installations) from them.

To do this, you need to first find your old DBMSs in your file system:

  • Go in the old desktop data directory.

  • Open the neo4jDatabases folder.

  • Now you should see a list of folders with a name following this format database-<id>.

  • Inside each of these folders there can be one or more folders named installation-<version>. If there are multiple installation folders, open only the one with the most recent version.

The content of the installation folder will look similar to this:

Then create the dump files:

  • Once inside an installation-<version> folder, open PowerShell in that location (shift + right click in the file explorer and click on "Open PowerShell window here").

  • Run the dump command (more info about it here). You can use whatever name you want in the --to argument, just make sure that it ends in .dump.

.\bin\neo4j-admin.bat dump --database=neo4j --to=dbname.dump
  • If successful you'll see a message similar to this:
Done: 73 files, 1.116MiB processed.

Finally, load the dump files into desktop:

  • Drag the .dump file that was just created into the corresponding project in Desktop.

  • Select "Create new DBMS from dump" on the options menu.

  • Make sure to select the same version the DBMS was running before. The patch number doesn't have to match, but the rest needs to be the same. So for example if your DBMS was using version 4.0.1 any 4.0.x version would be fine.

  • Click on "Create" and you're done.

Let me know if any steps are unclear, or if you come across any other issues in the process.

1 Like

I am also getting:
[2021-07-22 15:56:08.212] [error] Protocol Manager error TypeError [ERR_INVALID_URL]: Invalid URL: --allow-file-access-from-files
at onParseError (internal/url.js:256:9)
at new URL (internal/url.js:332:5)
at Object.t.default (C:\Program Files\Neo4j Desktop\resources\app.asar\dist\
at App. (C:\Program Files\Neo4j Desktop\resources\app.asar\dist\
at App.emit (events.js:315:20)
at App.EventEmitter.emit (domain.js:483:12)
at App.emitter.emit (C:\Program Files\Neo4j Desktop\resources\app.asar\node_modules@sentry\electron\dist\main\integrations\electron.js:66:25)

When I startup desktop or try to add an app. I renamed the .neo4jdesktop folder as well, but doesn't seem to fix it. I cannot add any apps, like GraphQL which I would like to use.

Thank you! I'm trying now.. what wrong with that?

Right, I forgot that neo4j-admin requires Java to run. You can run this command (before the dump command) to make the script use the same Java version that is bundled with Desktop:

$env:JAVA_HOME = "<desktop data path>\distributions\java\zulu11.41.23-ca-jdk11.0.8"

If you used this path

then the command would look like this for you:

$env:JAVA_HOME = "E:\Neo4jNewDatabase\distributions\java\zulu11.41.23-ca-jdk11.0.8"
1 Like

Hi @Bodeman, that sounds like a different issue, could you create a separate post for it?

That error is safe to ignore in most cases, but if you're having issues adding graph apps it could be relevant. Please also add the full log and explain how you're trying to install graph apps (as there are a few different ways to do that) to make it easier for people to help you.

Should I run this command in the previous path that I run the dump command? Or Can I change in Window's JAVA HOME variable?

Yes, right before running the dump command. That will set the JAVA_HOME environment variable for that PowerShell window.

1 Like

Is that correct?
When I copied and run that command "The filename, directory name, or volume label syntax is incorrect."...

It looks like you're running the command in the command prompt instead of PowerShell. Run powershell and then try again. Also the path needs to be surrounded by quotes.

1 Like

Thanks! :innocent:

1 Like

Thanks a million for your patient on my issues ! Now, I have already got my data back. It was successfully done as your kindly suggestions and commands with Neo4j Desktop new version. :innocent: I'll continue and use neo4j a lot more.. :smiley: Sometimes, I was misunderstood some solutions because of my worries... :innocent:

1 Like

Awesome! Happy that you got everything working!

1 Like

Understood. Thanks. Created new post: Invalid URL when adding any graph app to desktop