# Neo4j Community Edition AMI failing to deploy on AWS

**URL:** <https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505>\
**Category:** Neo4j Graph Platform\
**Created:** [October 16, 2023, 12:07pm UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505 "2023-10-16T12:07:35Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![stephen3](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/stephen3/32/27689_2.png) [@stephen3](https://community.neo4j.com/u/stephen3)\
**Post date:** [October 16, 2023, 12:07pm UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505/1 "2023-10-16T12:07:35Z")

</div>

I'm trying to deploy using CloudFormation from this listing on the AWS Marketplace [AWS Marketplace: Neo4j Community Edition](https://aws.amazon.com/marketplace/pp/prodview-lxxbmpqvwo5eq#pdp-support)

I've used this before (mid-September) and had no issues but for the last week I can't get it to deploy. Each time I try to deploy using CloudFormation the EC2 instance fails to deploy after a timeout, with errors in the EC2 cons (see the pastebin link below).

I've tried to deploy with multiple different instance types (r6i.large, t3.medium) but they all fail with the same error.

Anyone having the same issues? Anyone found a solution?

[Pastebin link to console logs](https://pastebin.com/TrVDh33A)

---

<div class="post-metadata">

**Author:** ![harshit.singhvi](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/harshit.singhvi/32/21394_2.png) [@harshit.singhvi](https://community.neo4j.com/u/harshit.singhvi)\
**Post date:** [October 18, 2023, 8:55am UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505/2 "2023-10-18T08:55:43Z")

</div>

@stephen3 i just tried the Neo4j Community Edition on the AWS Marketplace and its working just fine.

 ![Screenshot 2023-10-18 at 09.52.50](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/0/e/0e69214f1cca71fe2b2fea3a4946ba5b853920b1.png)  
 ![Screenshot 2023-10-18 at 09.54.47](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/6/6/6627fe56678e00c70c3dbfc7b06c0e407b18a2c5.png)  
 ![Screenshot 2023-10-18 at 09.55.25](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/8/2/82fe204a6e258571213be0b9ff15ea6817603426.png)

---

<div class="post-metadata">

**Author:** ![stephen3](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/stephen3/32/27689_2.png) [@stephen3](https://community.neo4j.com/u/stephen3)\
**Post date:** [October 18, 2023, 12:09pm UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505/3 "2023-10-18T12:09:08Z")

</div>

How strange! I assume you're using the recommended r6i.large EC2 instance? I'll try again and see if I'm having the same issues.

---

<div class="post-metadata">

**Author:** ![harshit.singhvi](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/harshit.singhvi/32/21394_2.png) [@harshit.singhvi](https://community.neo4j.com/u/harshit.singhvi)\
**Post date:** [October 18, 2023, 12:33pm UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505/4 "2023-10-18T12:33:24Z")

</div>

Even with r6i.large it comes up fine

 ![Screenshot 2023-10-18 at 13.32.28](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/6/1/613c94b6f5f68578b041d50d9cde7599d608f8ba.png)  
 ![Screenshot 2023-10-18 at 13.32.32](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/7/4/74ee5c275c45acc72976262c9fb6864134d54bdc.png)

---

<div class="post-metadata">

**Author:** ![stephen3](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/stephen3/32/27689_2.png) [@stephen3](https://community.neo4j.com/u/stephen3)\
**Post date:** [October 21, 2023, 2:45pm UTC](https://community.neo4j.com/t/neo4j-community-edition-ami-failing-to-deploy-on-aws/64505/5 "2023-10-21T14:45:01Z")

</div>

Eventually, I got to the bottom of this after it continued happening, even across regions.

The password I was using/passing into CloudFormation included a '$' character and that broke the deployment. When I remove that character the deployment works fine.

So for future reference, don't use passwords with $ signs in them.
