Neo4j Commander

yes there is a deep link:

neo4j-desktop://graphapps/neo4j-browser?cmd=edit&arg=match%20(n)%20return%n

see: https://github.com/neo4j/neo4j-browser/pull/956

1 Like

Great news! thanks so much.

Graph app gallery is currently a static page, that we can add your app to after testing.
Did you test with 4.x and 3.x and the latest desktop (1.2.9) ?

Signing is currently for internal/labs apps. If you need extra permissions you can declare them and afaik that's not questioned with signing.

Signing soon(ish) for partners and at some point for external contributors.

Btw. there is also activation key support that you can use to issue full-feature-activation to your fully licensed users.

Hi Michael,

deep-linking to neo4j browser:
I tried that and it didn't work for me, so I asked.
Will have to figure out what the problem is but to me it seemed like the web view opened by "desktop" completely ignores window.open or document.location.href ...

Activation key support: Looking into that .. THX!

Re: Graph App Gallery:

I have been using (=testing? ;)) my app on 4.0.3, 3.5.14 and 3.5.3
Yes, I have desktop version 1.2.9

Signing: FYI This is what I get when I drag & drop the TGZ onto the Install area. I am not asking for any special permissions in package.json / manifest

Gallery: So gallery is simply linking to a static URL on my side and I can exchange the underlying file there when I have a new version ready (currently this is daily since I am still adding features like crazy)?

Cheers, Chris

You should publish it to npm or a private npm repo and share that URL then you get auto updates. Otherwise not which we would not want for our users.

What exactly did not work with the deep link URL? Can you share what you used? URL and code?

Deep links: I was hoping that something like a

window.open('neo4j-desktop://graphapps/neo4j-browser?cmd=edit&arg=MATCH%20(n0)%20WHERE%20id(n0)%3D0%20RETURN%20n0')

when called from the app running inside of neo4j desktop would open the neo4j browser and paste the query ready to be executed.... but since that doesn't work I thought maybe there is a more direct way using neo4jDesktopApi

BTW
<a href="neo4j-desktop://graphapps/neo4j-browser?cmd=edit&amp;arg=MATCH%20(n0)%20WHERE%20id(n0)%3D0%20RETURN%20n0">test</a>
doesn't do anything either...

:poop: Just realized that there is a projekt called "yFiles Neo4j Explorer" that is also in the apps gallery.

Maybe we should rename our project to prevent confusion?

OK, rebranded it to "neo4j Commander"

Public NPM of trial version: https://www.npmjs.com/package/neo4jcommander

2 Likes

Can you check that your neo4j desktop is handling the URL prefix neo4j-desktop://?

There are different tools for the different operating systems that allow you to check/fix those.

Alrighty, I have finally managed to make Deep Linking to neo4j Desktop on Linux (Ubuntu / Gnome) work!

  1. Create /usr/share/applications/neo4j-desktop.desktop with this content:
[Desktop Entry]
Name=neo4j Desktop
Exec=<path to AppImage> %u
Path=<dir of AppImage>
Icon=<path to icon>
Terminal=false
Type=Application
Categories=Application

AppImage = neo4j-desktop-1.2.9-x86_64.AppImage at the time of writing

  1. execute

xdg-mime default neo4j-desktop.desktop x-scheme-handler/neo4j-desktop

to register "neo4j-desktop://" URLs to open with neo4j-desktop

  1. test from terminal:

xdg-open "neo4j-desktop://graphapps/neo4j-browser?cmd=edit&arg=MATCH%20(n0)%20WHERE%20id(n0)%3D0%20RETURN%20n01"

should open neo4j desktop and the neo4j browser and fill in the query ready to be executed

  1. test from browser:

enter the URL

neo4j-desktop://graphapps/neo4j-browser?cmd=edit&arg=MATCH%20(n0)%20WHERE%20id(n0)%3D0%20RETURN%20n01

in your browser and neo4j desktop should also open.

Note: worked in firefox and vivaldi (both asked if I wanted to open neo4j desktop) but did NOT work in Brave (didn't ask, simply opened search engine, don't know why yet)

As soon as this works correctly, it also works from within neo4j Commander:

Note to Graph App devs: window.open does not work, <a target="_blank"> does not work either.
It has to be a simple link like <a href="neo4j-desktop://graphapps...">...</a>

Hi @michael.hunger @adam.cowley @neo4j_devrel

What else needs to be done to get neo4j Commander onto the Apps Gallery?

Cheers, Chris

Hi @chris3, I think an article introducing it e.g. on medium.com/neo4j (you can submit an article to the publication if you give us your medium username).

Let's continue the detail discussion via email. I'll drop you a line.

Looks really great.

Give this man @chris3 a beer!

1 Like

Btw. the correct NPM URL to install neo4j commander into Neo4j Desktop is

https://registry.npmjs.org/neo4jcommander

1 Like

For everyone following this thread:

Read the article here:

And fire up neo4j Commander from the Apps Gallery in neo4j Desktop!

Thanks to the neo4j Team!!!
Cheers, Chris

1 Like

Hey guys,
please follow netbiz on twitter for neo4j Commander updates: https://twitter.com/netbizltd
THX!

it seems that deep links have stopped working... did something change?

using links like
neo4j-desktop://graphapps/neo4j-browser?cmd=edit&arg=MATCH....

but neo4j Browser never opens (neither from browser nor from app opened inside of neo4j Desktop)

using neo4j Desktop 1.3.4 in Windows 10