Neo4j 4.1.0, Database failed to start

Hello Community. I have an issue with 4.1.0 which seems to only show up if I create 2 databases in my desktop. The specific error message is:
Database failed to start: DB [database-cb86baa1-23ed-4a1d-9b4d-4498a4805c93] 'v4.1.0' exited with status 'KILLED'. Check the logs

and the log entries:

APOC couln't set a URLStreamHandlerFactory since some other tool already did this (e.g. tomcat). This means you cannot use s3:// or hdfs:// style URLs in APOC. This is caused by a limitation of the JVM which we cannot fix.
2020-06-26 23:20:33.597+0000 INFO Starting...
2020-06-26 23:20:36.381+0000 INFO ======== Neo4j 4.1.0 ========

As far as I know, APOC is current, and I do not have tomcat running on my laptop. I also dont know what "s3://" etc styles are. Would appreciate any help you can provide.

THanks * 1M

Had a "killed" issue recently where it turned out that there were two versions of APOC installed in the plugins/ folder of that database. This happened after upgrading via Neo4J Desktop.

Make sure there is only one, and that it is current.

Paul can you please assist on this one.

Even after having a single Jar in the plugins folder same failure is shown in the log file.

Neo4J: 4.0.6
Apoc: apoc-4.1.0.1-all.jar

log:
2020-07-21 09:21:56.664+0000 INFO ======== Neo4j 4.0.6 ========

2020-07-21 09:21:56.669+0000 INFO Starting...

2020-07-21 09:21:58.632+0000 ERROR Failed to start Neo4j: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@684b31de' was successfully initialized, but failed to start. Please see the attached cause exception "org.neo4j.configuration.GraphDatabaseInternalSettings". Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@684b31de' was successfully initialized, but failed to start. Please see the attached cause exception "org.neo4j.configuration.GraphDatabaseInternalSettings".

org.neo4j.server.ServerStartupException: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@684b31de' was successfully initialized, but failed to start. Please see the attached cause exception "org.neo4j.configuration.GraphDatabaseInternalSettings".

at org.neo4j.server.exception.ServerStartupErrors.translateToServerStartupError(ServerStartupErrors.java:45)

at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:164)

at org.neo4j.server.ServerBootstrapper.start(ServerBootstrapper.java:114)

at org.neo4j.server.ServerBootstrapper.start(ServerBootstrapper.java:89)

at org.neo4j.server.CommunityEntryPoint.main(CommunityEntryPoint.java:35)

Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@684b31de' was successfully initialized, but failed to start. Please see the attached cause exception "org.neo4j.configuration.GraphDatabaseInternalSettings".

at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:465)

at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:111)

at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:157)

... 3 more

hello. I removed all traces of Neo4j on my laptop and reinstalled. This seems to have solved the problems I have been having. Thanks for helping.

This is pretty ad-hoc, @rmasrani which community version of neo4j are you using?

@webtic would you please shed some light on the issue for shutdown. Thanks in advance.

You have (had?) mixed the Neo4J and APOC versions;

When on Neo4J 4.0 you need the APOC from the 4.0 branch; the latest is
4.0.0.17

The apoc-4.1.0.1-all.jar is for the 4.1 release

Hello.

My APOC version is in line with the Neo4j version – both are 4.1

Yet – this am – I got this error again (after I reinstalled everything):

An error occurred during update. Please see the logs.
If this error persists, go to https://neo4j.com/download to download the latest version.

In the log.log file, there are numerous checks but no errors.

The only line in the desktop log file is this:

APOC couln't set a URLStreamHandlerFactory since some other tool already did this (e.g. tomcat). This means you cannot use s3:// or hdfs:// style URLs in APOC. This is caused by a limitation of the JVM which we cannot fix.

I don’t have tomcat installed on my laptop.

This issue isn’t holding anything up. It is just daunting to see an error like this every morning :->

This appears to be a known issue ; https://github.com/neo4j-contrib/neo4j-apoc-procedures/issues/1571

Thanks for diffing this up Paul. Appreciate it.