Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app


(Stefan Armbruster) #9

It's not me, it's our wonderful "desktop team". :slight_smile:

(Sirajmunir93) #10

Sure thing "Team" is what all we need for "to the rescue" tasks :wink:

(Gibbonschas) #11

The "Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.
" error is still occurring on Version 1.1.17 (

(Curtis) #12

I am also getting this error with the Version 1.1.17 ( I have tried to reinstall, closed all browsers, restarted machine etc.

(Shammer64) #13

I too have run into this issue. I downloaded and created my first graph yesterday...used the browser for a few hours. Today, after restarting neo4j, I receive the error about the damaged browser. I see no way to resolve the issue, so I am now dead in the water. Sad. I'm running on Mac OS Mohave 10.14.3. Here's a screenshot...notice the spinner below the Browser in the list of Apps.

(Thomas Schrader) #14

Unfortunately, it is not solved: I installed today the neo4j desktop system completely after this error message ("Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app." ). I removed all directories with neo4j. Then, it startet properly. Nevertheless, I stopped my server and restarted it now and get the message again.
What the real solution of this problem?

(TerryP) #15

Nope. Nada. Nyet. 1.1.17 ( is not the solution. Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.

(TerryP) #16

This should be unmarked as "solved." It is not.

(Shammer64) #17

I’ve only had the latest version installed. Tried reinstalling. Same error when starting the browser. Software is unusable in this state.

(Alperen) #18

I installed Neo4j Desktop in Windows 10 yesterday. Because of this error, I uninstalled and reinstalled it, then the error occurred again after awhile. I am using the version 1.1.17 in Ubuntu 18.04 now, and it seems OK. I've had no problem since yesterday.

EDIT: I'm getting the same error in Ubuntu right now.

(M Kiuchi) #19


I've met same problem, and find workaround.

  • Start database from Neo4j Desktop(Windows 10 + N4JD 1.1.17)
  • Open http://localhost:7474 on your browser(Chrome, Firefox, etc) instead of Neo4j Browser

(oskarhane) #20

For you who it's not working for in Desktop v1.1.17: What version of Neo4j Browser do you have installed?
If you're on the latest (neo4j-browser v3.2.18), go to the Desktop data folder and try to delete the Application/graphApps/neo4j-browser folder and restart Neo4j Desktop and see if that makes a difference.

(oskarhane) #21

Also, please send me your log files (ctrl or cmd + k and type 'log') and select desktop log file to get to it. I'm available at oskar.hane at

(Sirajmunir93) #22

It was marked as solution as it resolved my problem. I ran into same problem with the previous update i.e. 1.1.16 and the newer update resolved my issue. My system config is win10 64bit Neo4j Desktop version 1.1.17 and my Neo4j browser version is 3.2.18 and it's working fine.

(Rajaskyrider) #23


I am also having same problem from Friday. I am using neo4j-browser v3.2.17 and Desktop v1.1.17 in Windows 10. I tried deleting the folder as you said. It unfortunately didn't make a difference. In the log file, I see the following.
[2019-03-18 12:30:42:0489] [error] Graph-App 'Neo4j Browser' execution blocked: signature verification failure.

Error: Installed Graph-App signature has been changed.
at f (C:\Users\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\
at process._tickCallback (internal/process/next_tick.js:68:7)

And btw I have no idea how to update the browser to v3.2.18.. Thank you.

(oskarhane) #24

Could you close Neo4j Desktop, start it and then grab the log file and send it to me please?

(Shammer64) #25

I am running on a MacBook, and I have Desktop 1.1.17 and Browser 3.2.17.

(Attachment log.log is missing)

(Rajaskyrider) #26

Mailed you the log file..

(Rajaskyrider) #27

Hello again,

I manually downloaded and added the Browser v3.2.18(from the url in the log file) and it works. However the browser v3.2.17 still gives me the same error (and also there is no way to remove it from the Application panel).

(oskarhane) #28

Thanks for the info!
Yes, it's the update that is failing for some reason. We are investigating at the moment.

The workaround for people having this issue is, as you say, install latest neo4j-browser as a separate graph app using: