Desktop 1.3.4 cannot create a 3.5 DB

current desktop 1.3.4 install cannot create a 3.5 DB
Any idea why older version of db are note accessible ? because of ISD restrictions the window account I'm working with is not admin , to get some admin privilege , I need to give another account's credential. Any idea if that could be the cause of old DB not showing up?image