Desktop 1.2.4, version 4.00 cannot open successfully filled db from version 3.5.14

Hi there,
trying to open db I get this error in log:
2020-01-15 15:49:04.468+0000 INFO ======== Neo4j 4.0.0 ========
2020-01-15 15:49:04.473+0000 INFO Starting...
2020-01-15 15:49:05.108+0000 ERROR Failed to start Neo4j: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@2bb3058' was successfully initialized, but failed to start. Please see the attached cause exception "'long org.jctools.util.UnsafeAccess.fieldOffset(java.lang.Class, java.lang.String)'". Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@2bb3058' was successfully initialized, but failed to start. Please see the attached cause exception "'long org.jctools.util.UnsafeAccess.fieldOffset(java.lang.Class, java.lang.String)'".
org.neo4j.server.ServerStartupException: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@2bb3058' was successfully initialized, but failed to start. Please see the attached cause exception "'long org.jctools.util.UnsafeAccess.fieldOffset(java.lang.Class, java.lang.String)'".
at org.neo4j.server.exception.ServerStartupErrors.translateToServerStartupError(ServerStartupErrors.java:45)
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:163)
at org.neo4j.server.ServerBootstrapper.start(ServerBootstrapper.java:114)
at org.neo4j.server.ServerBootstrapper.start(ServerBootstrapper.java:89)
at com.neo4j.server.enterprise.EnterpriseEntryPoint.main(EnterpriseEntryPoint.java:25)
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@2bb3058' was successfully initialized, but failed to start. Please see the attached cause exception "'long org.jctools.util.UnsafeAccess.fieldOffset(java.lang.Class, java.lang.String)'".
at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:465)
at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:111)
at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:156)
... 3 more
Caused by: java.lang.NoSuchMethodError: 'long org.jctools.util.UnsafeAccess.fieldOffset(java.lang.Class, java.lang.String)'
at org.jctools.queues.MpmcArrayQueueProducerIndexField.(MpmcArrayQueue.java:38)
at org.jctools.queues.QueueFactory.newQueue(QueueFactory.java:61)
at org.neo4j.kernel.impl.util.collection.CachingOffHeapBlockAllocator.(CachingOffHeapBlockAllocator.java:77)
at org.neo4j.graphdb.factory.module.GlobalModule.createCollectionsFactorySupplier(GlobalModule.java:395)
at org.neo4j.graphdb.factory.module.GlobalModule.(GlobalModule.java:184)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.createGlobalModule(DatabaseManagementServiceFactory.java:212)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.build(DatabaseManagementServiceFactory.java:117)
at com.neo4j.server.database.EnterpriseGraphFactory.newDatabaseManagementService(EnterpriseGraphFactory.java:38)
at org.neo4j.server.database.LifecycleManagingDatabaseService.start(LifecycleManagingDatabaseService.java:88)
at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:444)
... 5 more

What todo?
WJI

I can only assume relevant details of your setup.
Guessing you try to open a 3.5.14 database with desktop 1.2.4 and 4.0.0 drivers, I suggest:
a) export the 3.5.14 databases content facilitating "dump" into a file.
b) import that dump into the desktoop installation (using "load")

hi,
it's not the db, must be an incompatibility between desktop 1.2.4 and 4.0.0:
db in 4.0.0 had been force-imported from 3.5.14 version -> error
db can be dumped from 4.0.0 version, a reload today -> same error
force-imported the 3.5.14 dump to a new db works fine.
In my copy above I had not copied the two warnings bevore the logged error:

2020-01-17 08:21:19.873+0000 WARN  Use of deprecated setting dbms.active_database. It is replaced by dbms.default_database
2020-01-17 08:21:19.877+0000 WARN  Unrecognized setting. No declared setting with name: dbms.connector.bolt.address

perhaps there's some inconsistency in the 4.0.0 version I had simply upgraded.
BTW, first start of 4.0.0 necessitated java 11 with JAVA_HOME set, which my old java 8 hadn't.
WJI