# Connection Refused

**URL:** https://community.neo4j.com/t/connection-refused/59737
**Category:** Neo4j Graph Platform
**Tags:** migrated
**Created:** [August 5, 2022, 11:37pm UTC](https://community.neo4j.com/t/connection-refused/59737 "2022-08-05T23:37:27Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![TK36](https://avatars.discourse-cdn.com/v4/letter/t/f14d63/32.png) [@TK36](https://community.neo4j.com/u/TK36)
#### Post date: [August 5, 2022, 11:37pm UTC](https://community.neo4j.com/t/connection-refused/59737/1 "2022-08-05T23:37:27Z")

</div>

I have been using Neo4j on a ubuntu server for months, but I downloaded the dependencies for apoc.mongodb a few days ago, then restarted Neo4j following the instructions [here](https://neo4j.com/labs/apoc/4.2/overview/apoc.mongodb/apoc.mongodb.first/). I no longer can connect to Neo4j since I did this! I tried the browser and the shell. In both cases, I get "connection refused". The configuration file is the same, and nothing changed at all. I can't find any explanation for this!

Here is some detailed info that may be needed:

Neo4j version: 4.4.4 The command to restart neo4j: sudo systemctl restart neo4j.service The network configurations: dbms.default\_listen\_address= (I also tried 0.0.0.0)

Bolt connector:

dbms.connector.bolt.enabled=true

dbms.connector.bolt.tls\_level=DISABLED

dbms.connector.bolt.listen\_address=:0.0.0.0:7687

#dbms.connector.bolt.advertised\_address=:7687

HTTP Connector:

dbms.connector.http.enabled=true

dbms.connector.http.listen\_address=0.0.0.0:7474

#dbms.connector.http.advertised\_address=:7474

Can someone please help me solve this issue?

---

<div class="post-metadata">

### Author: ![michael.hunger](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/michael.hunger/32/27377_2.png) [@michael.hunger](https://community.neo4j.com/u/michael.hunger)
#### Post date: [August 9, 2022, 1:30pm UTC](https://community.neo4j.com/t/connection-refused/59737/2 "2022-08-09T13:30:20Z")

</div>

Check /var/log/neo4j/debug.log for any startup errors, it might be that you're missing a dependency.

Did you try to remove the apoc-mongodb dependencies if it works again then?

---

<div class="post-metadata">

### Author: ![TK36](https://avatars.discourse-cdn.com/v4/letter/t/f14d63/32.png) [@TK36](https://community.neo4j.com/u/TK36)
#### Post date: [August 10, 2022, 11:01pm UTC](https://community.neo4j.com/t/connection-refused/59737/3 "2022-08-10T23:01:34Z")

</div>

Removing the apoc-mongodb dependencies solved the problem
